Search This Blog

Fabric Externder

Fabric Extender 



1.Set up basic configuration

Switch(config)#hostname N5K-1
 N5K-1(config)#no ip domain-lookup
 N5K-1(config)#line console
 N5K-1(config)#exec-timeout 0
 N5K-1(config)#end
 N5K-1#coppy running-config startup-config
Notice:

  •  NX-OS does not support the write memory command
  •  VLAN Save on bootflash:vlan.dat 

2. Set up Vtp to mode Transparent

N5k-1#conf
 N5K-1(config)#feature vtp
 N5K-1(config)#vtp mode trandparent
 N5K-1(config)#Vtp domain Cisco1
 N5K-1(config)#Vtp password SWtest
3.Create the VLANs:
 N5k-1#conf
 N5K-1(config)#vlan 111
 N5K-1(config)#vlan 192
 N5K-1(config)#name SERVER
 N5K-1(config)#end
4.Add SVI interface
 N5k-1#conf
 N5K-1(config)#feature interface-vlan
 N5K-1(config)#int vlan 111
 N5K-1(config)#ip add 172.16.111.10/24
 N5K-1(config)#no shut
 N5K-1(config)#end
5.We first need to enable The Fex feature

 N5k-1#conf t
 N5k-1(config)#feature fex
 N5k-1(config)#end
                                                               FEX Set up                                      
6. Now set up an FEX device

 N5k-1(config)#fex 100
 N5k-1(config)#description FEX100
 N5k-1(config)#end
7. Set up the individual 10-Giabit interfaces that connect to the Fabric Extender as members of
port-channel 100.

N5k-1#conf t
N5k-1#(config)#interface e1/39-40
N5k-1#(config)#channel-group 100
Notice we don't need to using interface Range command like IOS.

8. Associate the port-channel with the Fabric Extender device

 N5k-1#conf 
 N5k-1#(config)#interface po100
 N5k-1#(config)#switchport mode fex-fabric
 N5k-1#(config)#fex associate 100
 N5k-1#(config)#end
 
9.Now we can set up SW Access for VLAN 192 apply on 5k-1 SW


 N5k-1#conf 
 N5k-1#(config)#inter e100/1/48
 N5k-1#(config)#switchport mode access
 N5k-1#(config)#switchport access vlan 192
 N5k-1#(config)#end
10.Set up trunk allow VLAN 111,192
 N5k-1#conf 
 N5k-1#(config)#interface e1/1
 N5k-1#(config)#switchport mode trunk
 N5k-1#(config)#switchport trunk allowed vlan 111,192
 N5k-1#(config)#end
11.Set the speed of the Nexus 5020 #1 e1/1 to 1000

Notice: Port 1-8 the Nexus5020#1 are capable of FastEthernet or Gigabit speed as well as 10 Gigabit. However, the hardware in use for this link doesn't support automatic negotiation of the speed , so we need to set the speed to Gigabit manually.

 N5k-1#conf 
 N5k-1#(config)inter e1/1
 N5k-1#(config)#speed 1000
 N5k-1#(config)#end

Verify command.
  • Show int e1/1 brief
  • Show vtp status
  • Show vtp password 
  • Show inteface trunk
  • Show fex detail
  • Show vlan -------------------on ios show VLAN brief 
  • Show port-channel summary -----in ios using show Etherchannel summary
  • Show interface brief | grep Po1
  • Show interface brief | grep Eth100
Notice
There are no line console 0 command only line console
There are no logging synchronous  command
If using VTP, LACP, or sign ip address for (SVI) must turn on feature

Now we will configure on 65000

1.Set up Basic Configuration

switch#conf t
 switch#hostname CORESW_6500
 CORESW_6500(config)#enabale secret cisco
 CORESW_6500(config)#no ip domain-lookup
 CORESW_6500(config)#line console 0
 CORESW_6500(config)#logging synchronized
 CORESW_6500(config)#end
2.Set up VTP and VLAN

 CORESE_6500#config
 CORESW_6500(config)#vtp mode transparent
 CORESW_6500(config)#vtp domain Cisco1
 CORESW_6500(config)#Vtp password SWtest
 CORESW_6500(config)#vlan 111
 CORESW_6500(config-vlan)#vlan 192
 CORESW_6500(config-vlan)#name SERVER
 Notice: VTP name and pass work must be same on 5k SW

3. Set up the port 1-gigabit interface for trunk, in this Case, we using on Slots 5 and 6
Notice: The port default to layer 3 mode show the switchport command is Required
             The 6500 Sw is running IOS 15.1 which doesn't require spaces between items in the
             Interface range command

 CORESE_6500#config
 CORESW_6500(config)#interface range G5/1,G6/1 
 CORESW_6500(config-if-range)#switchport trunk encapsulation do1q
 CORESW_6500(config-if-range)#switchport mode trunk
 CORESW_6500(config-if-range)#switchport trunk allowed vlan 111, 192
 CORESW_6500(config-if-range)#no shut
 CORESW_6500(config-if-range)#end
4.Set up the Gi5/2 port to use the RJ45 connector and to be trunk port for VLAN 192
 on the supervision that has 2. They default to STP so we need to select the Rj45.

 CORESE_6500#config
 CORESW_6500(config)#interface G5/2 
 CORESW_6500(config-if)#media-type rj45
 CORESW_6500(config-if)#switchport
 CORESW_6500(config-if)#switchport trunk encapsulation dot1q
 CORESW_6500(config-if)#switchport mode trunk
 CORESW_6500(config-if)#switchport trunk allowed vlan 192
 CORESW_6500(config-if)#no shut
 CORESW_6500(config-if)#end
5.Set up Svi for VLAN 111

 CORESE_6500#config
 CORESW_6500(config)#int vlan 111 
 CORESW_6500(config-if)#ip address 172.16.111.1 255.255.255.0
 CORESW_6500(config-if)#no shut 
Notice:

  • VLAN database  save on const_nvram:vlan.dat
  • On  IOS 15.x, as well as on NX-OS, are administratively down when created.









No comments: