This is the continue of Fex project.
1. Enable VPc and LACP features.
Configure the VPC peer-keepalive link using the management interface.
Notice we need to configure Keepalive link first before configuring VPC peer link.
4.Configure The VPC peer link as per the vPC/layer 2+3 diagram, allowing VLANs 1, 111, and192.
1.basic configure on N5k-2
1. Enable VPc and LACP features.
N5k-1#conf
N5K-1(config)#feature vpc
N5K-1(config)#feature lacp
N5K-1(config)#end
2.Configure the management IP interface and default route to Nexus 5020 #2 N5k-1#config t
N5K-1(config)#interface mgmt 0
N5K-1(config)#ip address 192.168.111.1/24
N5K-1(config)#vrf context managemnt
N5K-1(config)#feature vpc
N5K-1(config)#feature lacp
N5K-1(config-vrf)#ip route 0.0.0.0/0 192.168.111.2
N5K-1(config-vrf)#end
3.Create VPC domainConfigure the VPC peer-keepalive link using the management interface.
N5k-1#config t
N5K-1(config)#vpc domain 192
N5K-1(config-vpc-domain)#peer-keepalivce destination 192.168.111.2
N5K-1(config-vpc-domain)#end
Notice A vpc pair can use either the management interface or SVIs to set up the keepalive link. but this time we use the management interface.Notice we need to configure Keepalive link first before configuring VPC peer link.
4.Configure The VPC peer link as per the vPC/layer 2+3 diagram, allowing VLANs 1, 111, and192.
N5k-1(config)#interface e1/17-20
N5K-1(config-if-range)#channel-group 1 mode active
N5K-1(config-if-range)#interface po1
N5K-1(config-if)#vpc peer-link
N5K-1(config-if)#switchport mode trunk
N5K-1(config-if)#swicthport trunk allowed vlan 1,111,192
N5K-1(config-if)#end
5. Reconfigure Portchannel 100 for VPC 100 N5k-1#config t
N5K-1(config)#int po100
N5K-1(config-if)#vpc 100
N5K-1(config-if)#end
Let configure on SW 5k number 21.basic configure on N5k-2
switch#conf t
switch(config)#hostname N5K-2
N5K-2(config)#line console
N5K-2(config)#logging synchronized
N5K-2(config)#exec-timeout 0 0
N5K-2(config)#feature vtp
N5K-2(config)#feature interface-vlan
N5K-2(config)#feature fex
N5K-2(config)#feature vpc
N5K-2(config)#feature fex
N5K-2(config)#vtp mode transparent
N5K-2(config)#Vtp domain name Cisco1
N5K-2(config)#Vtp password SWtest
2.Configure VLAN and SVI interface.N5K-2(config)#Vlan 1,111 N5K-2(config-vlan)#vlan 192 N5K-2(config-vlan)#name SERVER N5K-2(config-vlan)#interface vlan111 N5k-2(config)#ip address 172.16.111.20/24 N5k-2(config)#no shut3.Set up FEX
N5K-2(config)#fex 100 N5K-2(config-fex)#description FEX100 N5K-2(config-fex)#interface e1/39-40 N5k-2(config)#channel-group 100 N5K-2(config)#interface po100 N5K-2(config)#switchport mode fex-fabric N5K-2(config)#fex associate 100 N5K-2(config)#end4.Set up VPC
N5k-2#config t
N5K-2(config)#interface mgmt 0
N5K-2(config)#ip address 192.168.111.2/24
N5K-2(config)#vrf context managemnt
N5K-2(config-vrf)#ip route 0.0.0.0/0 192.168.111.1
N5K-2(config)#vpc domain 192
N5K-2(config-vpc-domain)#peer-keepalivce destination 192.168.111.1
N5K-2(config-vpc-domain)#end
N5k-2(config)#interface e1/17-20
N5K-2(config-if-range)#channel-group 1 mode active
N5K-2(config-if-range)#interface po1
N5K-2(config-if)#vpc peer-link
N5K-2(config-if)#switchport mode trunk
N5K-2(config-if)#swicthport trunk allowed vlan 1,111,192
N5K-2(config-if)#end
5.Setup the uplink to the Catalyst 6500N5K-2(config)#int e1/1 N5K-2(config)#switchport mode trunk N5k-2(config)#switchport trunk allowed vlan 111,192 N5K-2(config)#speed 1000 N5K-2(config)#end5.Setup the e100/1/48 interface on Nexus 5020#2 to be an access port for VLAN 192
N5k-2#conf
N5k-2#(config)#inter e100/1/48
N5k-2#(config)#switchport mode access
N5k-2#(config)#switchport access vlan 192
N5k-2#(config)#end
No comments:
Post a Comment